升级 Flutter

我们强烈建议跟踪flutter的beta分支,这是Flutter稳定分支。 如果你需要查看最新的变化,你可以跟踪master分支,但注意这是开发分支,所以稳定性要低得多。

要查看您当前使用的分支,请运行flutter channel查看。

要切换分支,请使用flutter channel betaflutter channel master

为您的项目指定Flutter SDK

您可以在pubspec.yaml文件中指定Flutter SDK的依赖项。例如,以下代码片段指定flutterflutter_test包使用Flutter SDK。

name: hello_world
dependencies:
  flutter:
    sdk: flutter
dev_dependencies:
  flutter_test:
    sdk: flutter

不要使用pub getpub upgrade命令来管理你的依赖关系。相反,应该使用flutter packages getflutter packages upgrade。如果您想手动使用pub,则可以通过设置FLUTTER_ROOT环境变量来直接运行它。

升级 Flutter channel 和 packages

要同时更新Flutter SDK和你的依赖包,在你的应用程序根目录(包含pubspec.yaml文件的目录)中运行flutter upgrade 命令:

$ flutter upgrade

升级你的依赖包

如果您修改了pubspec.yaml文件,或者只想更新应用依赖的包(不包括Flutter SDK),请使用以下命令:

  • flutter packages get获取pubspec.yaml文件中列出的所有依赖包
  • flutter packages upgrade 获取pubspec.yaml文件中列出的所有依赖包的最新版本

我们向我们的邮件列表发布重大更新公告 。 我们强烈建议您订阅我们的通知。另外,我们很乐意听取您的意见!